Hi @Alan
Par Gilles FELIX , 26 septembre 2013 ·

Case Setup 2

Have you run the install wizard on the dedi server or did you just transferred files from your MAMP ?

What appen in back-office when you try to upload an image ? Can you open the browser console, if you're still in DEV environment you can have potential additionnal informations.

Case Setup 1

To be sure: you use install in shared hosting mode, without virtualhost ? What was the issue with virtualhost ?

Thanks for yours returns !

I ran the install on our dedi box after creating a subdomain in CPanel. I don't edit Vhosts directly.I installed via shell from github.
I had permission issues which i corrected - modsu_PHP doesn't like php files running with certain write permissions.

The installer complained that i didn't have mod rewrite enabled so I used the htaccess from shared hosts to force it to recognise it.

Installer then complained that i had a htaccess file i didnt need and renamed it.
THEN the installer ran its checks and passed.

Below may be irrelevant if the above indicates I made a mistake.

That being siad, when i add a picture i get a console error like below (I notice image file names with commas - is that normal?)

GET http://novius.[XXnameXX].com/cache/media/landscapes/test/s,512,512-fca6b6.jpg 404 (Not Found)
jQuery.extend.buildFragment jquery-1.9.1.js:6469
jQuery.fn.extend.domManip jquery-1.9.1.js:6129
jQuery.fn.extend.append jquery-1.9.1.js:5949
(anonymous function) jquery-1.9.1.js:6074
jQuery.extend.access jquery-1.9.1.js:852
jQuery.fn.extend.html jquery-1.9.1.js:6038
self.xhr.$.ajax.success jquery.novius-os.ostabs.js:1156
fire jquery-1.9.1.js:1037
self.fireWith jquery-1.9.1.js:1148
done jquery-1.9.1.js:8074
callback jquery-1.9.1.js:8598

When I click on my account i get an error with back trace like below:
######### error #########
An internal server error has been detected.

InvalidArgumentException [ Error ]: First parameter must be an array or ArrayAccess object.
COREPATH/classes/arr.php @ line 38

3: novius-os/framework/views/form/layout_standard.view.php @ line 30
8: novius-os/framework/applications/noviusos_user/views/admin/user_details_edit.view.php @ line 52
13: novius-os/framework/applications/noviusos_user/views/admin/account.view.php @ line 52
20: novius-os/htdocs/admin.php @ line 31
Par alan , 26 septembre 2013 ·
Hi @Alan

On which directory have you creating your subdomain ? Root directory of Novius OS or 'public' subdirectory (the good choice)

For the bug in my account, we have an other user that has the same issue. We investigate.
Par Gilles FELIX , 26 septembre 2013 ·

I've just push a bugfix for the "my account" issue.
If you've install with git, you can pull and update submodule to patch
Par Gilles FELIX , 26 septembre 2013 ·
thanks will try that.
Any ideas on media issues?
Par alan , 27 septembre 2013 ·
Hello Alan,

About the media issue, I can think of several causes that would trigger this issue, I'll ask you more information so we can figure out what's happening :

- Does the file gets created in local/data/media?
- Does the file gets created in public/cache/media?
- Do you have mod_xsendfile enabled in Apache?

The first two bullets should tell us whether you have a chmod issue, the last one if you have a misconfiguration with XSendFile.
Par Julian Espérat , 27 septembre 2013 ·
Thanks Julian:is XSendfile a necessary module?

Some of the images are in local/cache/media/myfolder/imagefile.jpg
but reported as 404's

This seems because the image its looking for is 's,64,64-2a4b99.jpg' but the actual image is called 's,256,256-c2e2c1.jpg'

the prefix makes me think it is getting confused between thumbnail -id .....

My folder are all 755 files 644
Par alan , 2 octobre 2013 ·
reinstalled via git - fresh install on existing db
get error warning 'ErrorException [ Warning ]: exec() has been disabled for security reasons
DOCROOT/htdocs/install.php @ line 657:'

When installing via git it looks like the folders are getting some 'insecure' permissions - eg the cache is written as world writeable which is not permitted under modsuphp. So I chmod around them.

Seems to work OK but...


When I add an image it immediately appears as broken.
I hit page refresh then it appears.
I try 'visulaisde' button - it appears broken.

Not quite there yet. It just seems to think its there but not until refreshed.....so it sort of works with manual refreshes

Par alan , 2 octobre 2013 ·
Hi Alan

All media files are store in the private directory /novius-os/local/data/media/
When you access a media for the first time, the 404 handle is invoked. It creates a symbolic link in the public/media directory, so subsequent requests don’t need to use the 404 handler anymore, and sent the file on the standard output. (See documentation link below for know why)

When you access a transform image (suffix like 's,256,256-c2e2c1.jpg') for the first time, the 404 handle is invoked. It transforms the image, stores the result in /novius-os/local/cache/media/, creates a symbolic link in the public/media directory, so subsequent requests don't need to use the 404 handler anymore, and sent the file on the standard output.

In your case, it seems that image is transformed, that the symbolic link is created but the file not send in the standard output the first time.
Do you have errors in logs/fuelphp or in apache logs ?
Par Gilles FELIX , 4 octobre 2013 ·
I did a refresh and checked permissions seems OK now..just have a load of other Qs.....:)
Par alan , 4 octobre 2013 ·
    ou Annuler
Serverr error accessign meida and my account
Par alan , 26 septembre 2013

Tried two setups of chiba

Setup 1. MAMP PRo on local dev

Setup 2. Dedi server Centos OS php 5.3 mod suPHP

Both GUI installs

Both not completely smooth. MAMP ok but needed to use shared htaccess host to get the install to work on our dedicated box.

Raw logs dont show much useful info.

Fuel log shows errors like:


ERROR - 2013-09-26 00:39:23 --> Error - First parameter must be an array or ArrayAccess object. in /home/xxxxxx/subdomains/novius/novius-os/fuel-core/classes/arr.php on line 38

I can add a blog post but I cant seem to upload images.

I suspect there is some issue with permissions /modsuPHP and  or bugs.

Any where else I can look to debug/pointers welcome :)