Hi @Mickk
Par Gilles FELIX , 19 septembre 2013 ·

The message can be confusing in your case. You've install Novius Os in a directory named novius-os (May be c:\wamp\novius-os\). And in Novius OS, we have also a directory named novius-os (containing others directories like framework or fuel-core).

You have to put the .htaccess file in the first novius-os (c:\wamp\novius-os\). Be carefull, if you have already put .htaccess in the second (c:\wamp\novius-os\novius-os\), delete it.

Other solution, change your server configuration, and set the DOCUMENT_ROOT to c:\wamp\novius-os\novius-os\, and restore the original .htaccess file of this directory (like after install).

TRied all the above and still saying the same.
Par Mickk , 19 septembre 2013 ·
Is there a different download for the windows version?
Par Mickk , 19 septembre 2013 ·
No, it's the same download.

Can you give us the content of the .htaccess file ?
Par Gilles FELIX , 19 septembre 2013 ·
# NOVIUS OS - Web OS for digital communication
#
# @copyright 2011 Novius
# @license GNU Affero General Public License v3 or (at your option) any later version
# http://www.gnu.org/licenses/agpl-3.0.html
# @link http://www.novius-os.org

Options +FollowSymLinks -Indexes

# Replace novius-os-install-dir by the real Novius OS installed directory
ErrorDocument 404 /novius-os\public/htdocs/novius-os/404.php

<IfModule mod_version.c>
<IfVersion >= 2.4>
DirectoryIndex disabled
</IfVersion>
</IfModule>

<IfModule !mod_version.c>
DirectoryIndex disabled
</IfModule>

## Post-installation optimisation
#<IfModule xsendfile_module>
#XSendFile On

## Replace "novius-os-install-dir" by the real Novius OS installed directory
#XSendFilePath /novius-os\local/data

#</IfModule>

<IfModule mod_rewrite.c>
RewriteEngine on

# Entry point for back-office controller URL
RewriteRule ^(admin(|/.*))$ public/htdocs/novius-os/admin.php [QSA,PT]

# Entry point for front office
RewriteRule ^([^\.]*)$ public/htdocs/novius-os/front.php [QSA,PT]
RewriteRule ^.+(\.html|/)$ public/htdocs/novius-os/front.php [QSA,PT]

# Novius OS is not installed, redirect to install
RewriteCond !%{DOCUMENT_ROOT}/novius-os\public/htdocs/novius-os/front.php -f
RewriteRule ^public/htdocs/novius-os/front.php /novius-os\install.php [R,L]

# do nothing for URL begining with a folder in public/(static|cache|media|data|htdocs)
RewriteRule ^public/(static|cache|media|data|htdocs)/ - [L]

# Redirect URL not begining with public folder to public
RewriteRule ^(static|cache|media|data|htdocs)/(.*) public/$1/$2 [L]

# Abstraction of htdocs directory in public
RewriteRule ^(.*) public/htdocs/$1 [L]
</IfModule>
Par Mickk , 19 septembre 2013 ·
Try with that (I change all \ by a / in paths)
Par Gilles FELIX , 19 septembre 2013 ·

# NOVIUS OS - Web OS for digital communication
#
# @copyright 2011 Novius
# @license GNU Affero General Public License v3 or (at your option) any later version
# http://www.gnu.org/licenses/agpl-3.0.html
# @link http://www.novius-os.org

Options +FollowSymLinks -Indexes

# Replace novius-os-install-dir by the real Novius OS installed directory
ErrorDocument 404 /novius-os/public/htdocs/novius-os/404.php

<IfModule mod_version.c>
<IfVersion >= 2.4>
DirectoryIndex disabled
</IfVersion>
</IfModule>

<IfModule !mod_version.c>
DirectoryIndex disabled
</IfModule>

## Post-installation optimisation
#<IfModule xsendfile_module>
#XSendFile On

## Replace "novius-os-install-dir" by the real Novius OS installed directory
#XSendFilePath /novius-os\local/data

#</IfModule>

<IfModule mod_rewrite.c>
RewriteEngine on

# Entry point for back-office controller URL
RewriteRule ^(admin(|/.*))$ public/htdocs/novius-os/admin.php [QSA,PT]

# Entry point for front office
RewriteRule ^([^\.]*)$ public/htdocs/novius-os/front.php [QSA,PT]
RewriteRule ^.+(\.html|/)$ public/htdocs/novius-os/front.php [QSA,PT]

# Novius OS is not installed, redirect to install
RewriteCond !%{DOCUMENT_ROOT}/novius-os/public/htdocs/novius-os/front.php -f
RewriteRule ^public/htdocs/novius-os/front.php /novius-os\install.php [R,L]

# do nothing for URL begining with a folder in public/(static|cache|media|data|htdocs)
RewriteRule ^public/(static|cache|media|data|htdocs)/ - [L]

# Redirect URL not begining with public folder to public
RewriteRule ^(static|cache|media|data|htdocs)/(.*) public/$1/$2 [L]

# Abstraction of htdocs directory in public
RewriteRule ^(.*) public/htdocs/$1 [L]
</IfModule>

Hi,

What is your windows version ? What is the HTTP server ?
Par Gilles FELIX , 20 septembre 2013 ·
I am using a windows web server 2008 R2 and http 1.1
Par Mickk , 20 septembre 2013 ·
still struggling to get past this .htaccess step
Par Mickk , 20 septembre 2013 ·
Unfortunately for you, Novius OS come with default configuration for an Apache HTTP server (.htaccess is part of this configuration).

With windows web server 2008, you can install Novius OS with Wampserver for example.
Par Gilles FELIX , 20 septembre 2013 ·
À
    ou Annuler
issues with .htaccess file on installation
Par Mickk , 19 septembre 2013
À

I cannot get past the step below:

Upload this file in the Novius OS's directory of your hosting server (novius-os\).

I have uploaded the file and refreshed but still no joy. I am setting this up on a windows server.

Thanks

Mike