Hello Gary,

At this very early stage of Novius OS, we were more focused toward local installation or small self-hosted solutions.
Nevertheless we definitely want you to install Novius OS and are going to look into your problem today or tomorrow.

We'll come back to you when we have a solution.
Par Julian Espérat , 10 octobre 2012 ·
Hello again,

The team has just cooked a special release for you to test! Instructions follows:

1. upload the new .zip file (novius-os.pre-0.1.2.zip) into your web root directory ;
2. delete the public/.htaccess file ;
3. upload the attached .htaccess file into your web root directory (don't forget to rename it ".htaccess", remove the "rename-me" part) ;
4. browse to http://your.domain.com/install.php

Keep us posted!
Par Julian Espérat , 10 octobre 2012 ·
Hi !
I tried your special release on my hosted shared server but it didn't work. Actualy, I can't run it on the root directory of mydomain.com i'have my own blog at this url... So I tried on mydomain.com/noviusos/install.php but nothing happened.

Is it possible to install Novius OS on a sub directory ?
thanks
Par Mathias , 12 octobre 2012 ·
Hi everyone. We just release the 0.1.2 verison, which allows installation on a shared hosting and / or in a sub-directory. Go try it our, this should fix all your problems!

Cheers.
Par Julian Espérat , 23 octobre 2012 ·
First of all, thank you for taking the time to help me with this issue. I'm quite impressed with the level of response and going so far as to create a new version to help solve the issue. Thank you!

Unfortunately, I am still not able to run the installation on the server. I have followed your instructions (downloaded 0.1.2.zip, unpacked it, installed the contents of the Novius-OS folder at my root directory, deleted the .htaccess file from the Public folder, uploaded the revised .htaccess file to the root directory, and I go to www.mywebsite.com/install.php (and have even tried www.mywebsite.com/public/install.php and www.mywebsite.com) and I always get an error that says:
"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@mywebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

Do you have any suggestions as to what I might be doing wrong or how I might fix this?

Thanks again for all your help!

All best,

Gary
Par Gary , 24 octobre 2012 ·
From what you said i can't see what you are doing wrong.

The only thing I can think of is checking the error log file to see what's happening.
Par Julian Espérat , 24 octobre 2012 ·
I'm having the same problem as Gary; I'm so frustrated that I'm willing to pay $40 to somebody who do me the favor of installing the novius on my share host. Anyone interested?
Par jherrera3 , 29 octobre 2012 ·
The 500 Internal Server Error could be caused by something not recognised in our .htaccess file. But apparently the 404 ErrorDocument is triggered... Which means the file has been read and take into account.

Meanwhile without the log we can't be sure.

I just noticed you said "I uplaoded the revised .htaccess file", but this "revised" .htaccess file is already included in the final 0.1.2 package. It's named ".htaccess.shared-hosting", you just have to rename it.

All the testing from our side could not reproduce the error, but there must clearly be something wrong if you can't succeed.

We definitely need the Error Log information to figure out what's happening now.
Par Julian Espérat , 29 octobre 2012 ·
This is the error that is placed on my error log: "[Mon Oct 29 12:40:58 2012] [error] [client 109.169.66.100] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace."
Par jherrera3 , 29 octobre 2012 ·
Can somebody help me please? I need to install this urgently....
Par jherrera3 , 29 octobre 2012 ·
If you're using the ".htaccess.shared-hosting" file, changed the directory where you installed it inside it. Then try removing this line:
RewriteRule ^/(.*) public/htdocs/$1 [L]

Also, the root will not work until you followed the steps from install.php
Par Julian Espérat , 30 octobre 2012 ·
Ok, so I got it to the point where I go through the install process in my browser. But, when I get to Step 4 and click on the "Go to Admin Panel" link I get the error "No input file specified". I've pull the logs and have attached them. Any advice is greatly appreciated.
-Gary

<?php defined('COREPATH') or exit('No direct script access allowed'); ?>

Error - 2012-10-30 23:49:24 --> 2 - reset() expects parameter 1 to be array, null given in /home/website/website.com/novius-os/framework/classes/permission.php on line 42
Error - 2012-10-30 23:49:24 --> 8 - Trying to get property of non-object in /home/website/website.com/novius-os/framework/classes/permission.php on line 45
Error - 2012-10-30 23:49:24 --> 2 - reset() expects parameter 1 to be array, null given in /home/website/website.com/novius-os/framework/classes/permission.php on line 42
Error - 2012-10-30 23:49:24 --> 8 - Trying to get property of non-object in /home/website/website.com/novius-os/framework/classes/permission.php on line 45
Error - 2012-10-30 23:49:43 --> 8 - Trying to get property of non-object in /home/website/website.com/novius-os/framework/classes/model/user.model.php on line 73

And here is the permission.php file:

<?php
/**
* NOVIUS OS - Web OS for digital communication
*
* @copyright 2011 Novius
* @license GNU Affero General Public License v3 or (at your option) any later version
* http://www.gnu.org/licenses/agpl-3.0.html
* @link http://www.novius-os.org
*/

namespace Nos;

class Permission
{
public static function forge($app_name, $key, $driver_config)
{
$driver = $driver_config['driver'];
// @todo Inflector::words_to_upper ?
$class = '\Nos\Permission_'.ucfirst($driver);

if (empty($driver_config['label'])) {
\Debug::dump($driver_config);
}

if (class_exists($class)) {
return new $class($app_name, $key, $driver_config['label'], $driver_config['driver_config']);
}
throw new \Exception('The permission driver '.$driver.' has not be found for application '.$app_name.' ('.$key.').');
}

public static function check($app, $key)
{
$user = \Session::user();
$role = reset($user->roles);

return $role->check_permission($app, $key);
}

public static function add($app, $key)
{
$user = \Session::user();
$role = reset($user->roles);
try {
$access = new Model_User_Permission();
$access->perm_role_id = $role->role_id;
$access->perm_application = $key;
$access->perm_identifier = '';
$access->perm_key = $app;
$access->save();
} catch (\Exception $e) {

}

return true;
}
}
Par Gary , 31 octobre 2012 ·
À
    ou Annuler
Hosted Server Installation
Par Gary , 9 octobre 2012
À

Hi there,

I'm looking at installing Novius OS as my CMS for my business' website.  I have a hosted (shared) server account through www.dreamhost.com which utilizes Php 5.3, Apache Websever, and MySQL 5.0.51a.  I've read and researched all the documentation on novius-os.org, github, and google and have tried to figure out how to install novius on my server, but I have been unsuccessful.  I downloaded the novius os zip flies to my mac, unzipped them, and FTP'ed the un-zipped files to the root directory of my domain.  Installation has been unsuccessful with the only error message referring me to github for installation instructions.  The installation instructions assume that I am self-hosting and I am using localhost, which neither are correct in my case.

So my questions are: 1.  Is it possible to install Novius OS on a hosted server (as described above)?  2. If so, what am I doing wrong and how do I correct my mistake(s)?  

This has been very frustrating, but I guess it just shows that I don't know what the hell I'm doing.  Thanks in advance for any help you can offer!

All best,

Gary